phpMyAdmin 4.6.6 + php 7.2 = warning

Vi è capitata l’accoppiata vincente phpMyAdmin 4.6.6 + php 7.2? Avete questo errore? “Warning in ./libraries/sql.lib.php#613 count(): Parameter must be an array or an object that implements Countable” Dopo aver fatto quattro risate, per fortuna la soluzione è semplice. Aprire il file /usr/share/phpmyadmin/libraries/sql.lib.php e cercare la funzione PMA_isRememberSortingOrder A questo punto correggere quanto segue. Bisogna…

Leggi tutto

mySQL 5.7: abilitare root login su phpmyadmin

Breve storia triste. Premesso che non è buona norma loggarsi come root, talvolta può succedere di averne necessità per qualche motivo. Bene… con l’aggiornamento a mysql 5.7, ciò non è più possibile, se non da shell in locale. Ne consegue che da phpmyadmin e/o altri client a piacere, riceveremo errori come i seguenti:    …

Leggi tutto